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Getting started with the eBUS-Vision
Package

The eBUS-Vision Package is a complete set of tools for configuring and controlling your iPORT IP
Engine and camera. Coyote is a simple-yet-powerful program that lets you use your IP Engine to
capture your first images. Then, as you familiarize yourself with the eBUS-Vision Package, you can
create your own application with the SDKs.
The eBUS-Vision Package lets you go from concept to prototype to finished product!
In this section:
Getting started.............................................................................................................. 7
Going further................................................................................................................ 7

Getting started
To acquire your first images using the eBUS-Vision Package:
1.
2.
3.
4.
5.
6.

Insert your software CD in your PC and install the eBUS-Vision Package. During this step, you will
install the NIC driver that best meets your needs.
Cable your camera, IP Engine, and PC together. See “Cabling your camera to your PC” on page 9.
If you’re using Windows XP, configure the firewall. See “Configuring the Windows XP Firewall”
on page 15.
Launch Coyote. See “Launching Coyote” on page 21.
Connect to your IP Engine. See “Connecting to your IP Engine” on page 27.
Acquire your first images. See “Acquiring images” on page 29.

Going further
Once you’ve acquired your first images, you can:
• Use the advanced configurations and controls in Coyote. See the iPORT Coyote Software
Guide.
• Use your IP Engine to control external machinery. See the iPORT Programmable Logic
Controller Reference Guide.
• Write your own program! See “Using the iPORT SDK” on page 27.
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Cabling your camera to your PC

When it comes to cabling, your iPORT IP Engine gives you a lot of flexibility. However, if you’re
cabling it for the first time, we recommend that you make a dedicated connection between your IP
Engine and PC.
To cable your camera to your PC:
• Cable your system as described in either “Dedicated connection” on page 9 or “Dedicated
connection with a second regular NIC” on page 9. Power cables aren’t shown.

Dedicated connection
If you require a very high bandwidth connection to your IP Engine but don’t require corporate network
connectivity, use the configuration below.
PC

Camera

IP Engine

NIC

Video cable
Ethernet cable
For best performance,
use Intel PRO/1000 NIC
This configuration might be used for a standalone machine vision system. For best performance, cable
your IP Engine to an Intel PRO/1000 NIC. The Intel PRO/1000 NIC is reliable and lets you use the
efficient eBUS Optimal Driver.

Dedicated connection with a second regular NIC
If you intend to use your NIC as a dedicated connection to your camera, use the configuration below. In
this configuration, you have a second NIC for corporate network connectivity.
PC
To office network
and Internet
NIC

Camera

IP Engine
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Switched connection (not recommended for first-time use)
If you intend to use a single NIC for both the connection to your camera and corporate network connectivity, use the configuration below.
PC
To office network
and Internet

Switch
Camera

IP Engine

NIC

If you’re setting up your IP Engine for the first time, we advise against using this configuration. Such an
arrangement may cause the following problems:
• You may experience data loss, delay, or network slowdowns if the switch employs blocking
architecture or insufficient packet forwarding capability.
• You may experience connectivity problems due to a switch that is nonstandard or improperly
configured (jumbo frames not enabled).
• Switches that use a spanning tree algorithm often incur a significant delay (several minutes)
when establishing a connection between a PC and the IP Engine. We recommend that you turn
off spanning tree implementations on the switch (check with your network administrator).
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Understanding drivers

In this section:
Quick pick...................................................................................................................11
Understanding drivers.................................................................................................11
Choosing your driver ................................................................................................. 12

Quick pick
In general, the eBUS Universal Driver is a good, all-round choice.

Understanding drivers
A regular manufacturer’s NIC driver receives Ethernet packets and passes them on to the Windows
network stack. The network stack analyzes the headers from each layer.
However, for each packet, the network stack may have to perform hundreds of tests before routing the
packet. The many decisions incur a heavy CPU usage penalty. The job of analyzing incoming packets
overwhelms the CPU long before data throughput reaches the NIC’s potential.
Regular NIC d river performance

Slow
down!
Data in

PC

CPU
usage
for
packets

CPU
available
for other
purposes

Bandwidth

A Pleora driver tests only for data destined for your application. If so, the data bypasses the network
stack to efficiently route data to your application. If not, the packet is sent to the Windows network
stack. Since the great majority of the data will be for your high-bandwidth application, Pleora drivers
dramatically reduce CPU usage. By eliminating the CPU usage bottleneck, data throughput is
maximized and your CPU is free to perform other duties.
eBUS driver performance

Data in

PC
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Choosing your driver
Pleora offers two eBUS drivers. If you’re using an Intel PRO/1000 network card, we recommend the
eBUS Optimal Driver. Otherwise, use the eBUS Universal Driver. If you’ve already got a project in
development, you can use continue to use the iPORT High-Performance IP Device Driver.
Comparison of Pleora NIC drivers
Category

eBUS Optimal Driver

eBUS Universal
Driver

iPORT High-Performance IP Device
Drivera

Manufacturer’s NIC
driver

Efficiency
Usage

High bandwidth, CPUintensive applications

High bandwidth applica- Existing projects requirtions that can tolerate
ing high-bandwidth
some sharing of CPU
capacity

Temporary

Works with
eBUS-PureGEV Package
Works with
eBUS-Vision Package
Limitations
Requires Intel PRO/1000
NIC and 825xx chips

To upgrade...

Requires Intel PRO/1000
NIC and 825xx chips
No support for corporate
office connectivity
(Internet)
Good choice – no change Good choice – no change Replace with eBUS
Replace with
required
required
Optimal Driver
eBUS Universal Driver

a. The iPORT High-Performance IP Device Driver isn’t available with the eBUS-PureGEV Package. If you’re migrating to the eBUS-PureGEV
Package or wish to use the same driver for all your products, use an eBUS driver.

eBUS Optimal Driver
The eBUS Optimal Driver is our recommended driver for demanding applications. The driver is a
purpose-built replacement for the regular driver that comes with your Intel PRO/1000 card or 825xx
chip. Designed to maximize throughput and minimize CPU usage, it’s ideal for high-bandwidth applications that need virtually all the CPU for other tasks. It also supports corporate network connectivity.

eBUS Universal Driver
The eBUS Universal Driver replaces the CPU-intensive Windows network stack. It works with almost
any NIC because it works in conjunction with your NIC manufacturer’s driver. The eBUS Universal
Driver supports corporate network connectivity.

iPORT High-Performance IP Device Driver
If you’re upgrading your iPORT SDK, already have an existing project under development, and you
don’t require a GigE Vision compliant connection, we recommend that you continue using the iPORT
High-Performance IP Device Driver – it has a solid track record of field-proven reliability. In short, if
your current system is working well, there’s no need to change.
The iPORT High-Performance IP Device Driver is extremely efficient but disregards regular Internet
traffic. As a result, it doesn’t support corporate network connectivity.
If you wish to upgrade, consider the eBUS Optimal Driver.

Copyright © 2008 Pleora Technologies Inc.

13

Manufacturer’s NIC driver
The manufacturer’s NIC driver is the default driver that comes with your NIC.
Your manufacturer’s NIC driver routes data through the Windows network stack. Though suitable for
bandwidths of 100 Mb/s or less, higher bandwidths incur a significant CPU usage penalty. Bandwidth is
limited when CPU usage reaches 100%. By devoting all its resources to packet routing, the PC is left
with insufficient CPU resources for other tasks (such as processing or displaying images).
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Configuring the Windows XP Firewall

In its default configuration, the Windows XP Firewall may block certain network packets between your
IP Engine and your image-acquisition program (e.g. Coyote, GEVPlayer, or your own program).
Follow the directions to ensure Windows XP Firewall lets your programs work as you expect. Finally,
and only if you prefer, you can use the directions to disable the firewall completely.
If you’re using Windows Vista, you don’t need to make any changes.
To configure the Windows XP Firewall:
1.
2.
3.
4.
5.
6.
7.

From the Windows Start menu, select Start > Control Panel.
The Control Panel appears.
Open the Windows Firewall.
If the firewall is set to Off (such as for closed systems), no further changes are required.
On the General tab, allow exceptions (Uncheck Don’t allow exceptions).
Select the Exceptions tab.
Click Add Program.
The Add a Program dialog appears.
Select your program (e.g. Coyote, GEVPlayer, or your own program) and click OK.
The Add a Program dialog closes and your program appears in the Programs and Services field.
Click OK to close the Windows Firewall dialog.
The Windows XP Firewall now allows your program to send and receive network packets.
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Configuring your NIC

If you’re in a typical networked office environment, your NIC will get its IP address from a DHCP
server. However, if you’re setting up for the first time, we recommend that you make a direct connection
to your iPORT IP Engine. Without a DHCP server, Windows uses Zeroconf (also known as Autoconf or
LLA fallback), but the fallback takes up to a minute every time you disconnect.
To connect faster, you can configure a static IP address. See “Dedicated connection (static IP address)”
on page 17.
If you want to configure your NIC to get its IP address from a DHCP server, see “Multi-use connection
(DHCP server)” on page 18.

Dedicated connection (static IP address)
This configuration assigns your NIC a static IP address.
To configure your NIC for a dedicated connection:
1.

Make the following selections:
In Windows XP: From the Windows Start menu, select Start > Control Panel > Network
Connections.
In Windows Vista: From the Windows Start menu, select Start > Control Panel > Network
and Sharing Center > Manage Network Connections.

2.

Right-click your Local Area Connection and select Properties.
The Local Area Connection Properties dialog appears.

3.

Make the following settings:
Client for Microsoft Networks
File and Printer Sharing for Microsoft Networks
QoS Packet Scheduler
Copyright © 2008 Pleora Technologies Inc.
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Internet Protocol (TCP/IP)
Show icon in notification area when connected
Notify me when this connection has limited or no connectivity
4.

Select Internet Protocol (TCP/IP) and click Properties.
The Internet Protocol (TCP/IP) Properties dialog appears.

5.

Enable Use the following IP address and make the following settings:
IP address
192.168.101.001
Subnet mask
255.255.255.0
Default gateway
leave blank
Ensure you’re not conflicting with an existing IP address on another NIC. For multiple dedicated
connections on the same host PC, increment the third IP address by one for each NIC (i.e. 101, 102,
103, etc.).
Click OK to close the Internet Protocol (TCP/IP) Properties dialog.
Click Close to close the Local Area Connection Properties dialog.
Your NIC is now configured for a dedicated connection. When you cable your NIC to another NIC,
Windows will recognize the connection without any delay.

6.
7.

Multi-use connection (DHCP server)
If you’re using your NIC for both your eBUS data and your regular office network connectivity,
configure it as a multi-use connection. This configuration is generic and presumes your office network
uses a DHCP server. For the exact settings for your network, consult with your company’s IT
department.
To configure your NIC for a multi-use connection:
1.
2.

From the Windows Start menu, select Start > Control Panel.
The Control Panel dialog appears.
Double-click Network Connections.
The Network Connections dialog appears.
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3.

Right-click your Local Area Connection and select Properties.
The Local Area Connection Properties dialog appears.

4.

Make the following settings:
Client for Microsoft Networks
File and Printer Sharing for Microsoft Networks
QoS Packet Scheduler
Internet Protocol (TCP/IP)
Show icon in notification are when connected
Notify me when this connection has limited or no connectivity

5.

Select Internet Protocol (TCP/IP) and click Properties.
The Internet Protocol (TCP/IP) Properties dialog appears.

6.
7.
8.
9.

Enable Obtain an IP address automatically.
Enable Obtain DNS server address automatically.
Click OK to close the Internet Protocol (TCP/IP) Properties dialog.
Click Close to close the Local Area Connection Properties dialog.
Your NIC will now get its IP address from a DHCP server.
Copyright © 2008 Pleora Technologies Inc.
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Connecting to your iPORT IP Engine

Coyote is a powerful and versatile camera interface application that lets you quickly configure your
iPORT IP Engine and begin capturing camera images with your PC.
To connect to your iPORT IP Engine:
1.
2.
3.
4.

Start Coyote. See “Launching Coyote” on page 21.
Click Detect to find your iPORT IP Engine on your network. See “Detecting your iPORT IP
Engine on your network” on page 21.
Click Select to select a camera. See “Selecting your camera” on page 23.
Click Connect to connect your PC to your IP Engine and camera.

Launching Coyote
Before launching Coyote, ensure that your camera and iPORT IP Engine are properly connected and
powered. Ensure that your NIC has the appropriate driver. To learn more, see “Getting started with the
eBUS-Vision Package” on page 7.
To launch Coyote:
• From the Windows Start menu, select Start > All Programs > Pleora Technologies Inc > eBUSVision Package > Coyote Application.
The main page of the Coyote application appears.

Detecting your iPORT IP Engine on your network
When you detect IP Engines, Coyote finds all the IP Engines it can, using all the NICs on your PC as
well as any that are indirectly connected through switches.
To detect your iPORT IP Engine:
1.

Start Coyote. See “Launching Coyote” on page 21.
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2.

In the IP Engine settings pane, click Detect.
The IP Engine selection dialog appears, listing the iPORT IP Engines that each NIC found. NICs
connected to a switched network may find multiple IP Engines.

3.

In the Available IP Engines pane, select your IP Engine.
Information about your selection appears in the IP Engine and NIC information pane.

4.

Click OK.
The Set IP Engine IP address dialog appears.

5.

In the IP Engine settings pane, enter the IP address and Subnet mask. If you’re connecting to your
iPORT IP Engine through a network switch (not recommended for an initial connection), consult
with your office IT department to ensure that your chosen IP address isn’t used by another machine.
The Warnings pane lets you know if values you enter are valid.
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6.

Click OK to close the IP Engine selection dialog.
The updated information appears in the IP engine settings pane.

To speed the process of connecting to your iPORT IP Engine in the future, see ““Saving your
settings” on page 24. Proceed to “Acquiring images with your camera” on page 25.

Selecting your camera
Coyote requires that you specify your camera when you connect to your IP Engine. However, in some
cases, you may want to connect without a camera. For example, you may be trying to connect to the IP
Engine for the first time or you might be following the tutorials described in the iPORT Programmable
Logic Controller Reference Guide. When prompted, choose the first camera on the list (without that
camera you obviously won’t be able to acquire any images.)
For a better understanding of what the selections mean, see “Acquiring images with your camera” on
page 25.
To select your camera:
1.

From the main page of Coyote, click Select.
The Select Camera dialog appears with a list of all cameras supported by the IP Engine.

2.

Select a camera and click OK. Only cameras supported by your IP Engine will appear.
The Select Camera dialog closes and your selection appears on the main page of Coyote.

Testing your connection
When you connect to an IP Engine for the first time using an eBUS driver, Windows recognizes the IP
Engine as new hardware.
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To test your iPORT IP Engine:
• From Coyote’s menu, select IP Engine > Test connection.
A dialog appears explaining the results of the test.

Saving your settings
To avoid reconfiguring every time you restart the program, Coyote lets you save your current settings as
an XML file.
The XML file contains all the information for your iPORT connection, plus all the information for your
camera connection (described in “Acquiring images with your camera” on page 25).
To save the settings for your iPORT IP Engine and camera:
1.
2.

From the main menu, select File > Save.
Type your file name and click Save.
Coyote saves your configuration.

To load the settings for your iPORT IP Engine and camera:
1.
2.
3.

Launch Coyote. See “Launching Coyote” on page 21.
From the main menu, select File > Open.
Select your file and click Open.
Coyote loads your saved configuration. (If File > Ignore connectivity information is checked,
you have to manually connect to your IP Engine before loading the settings. See the iPORT Coyote
Software Guide.)
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Acquiring images with your camera

Now that you’ve connected your iPORT IP Engine, you can connect to your camera and begin acquiring
images. To acquire images successfully, you must ensure that Coyote, the IP Engine, and your camera
have the same settings.
For full details for using and configuring Coyote, see the iPORT Coyote Software Guide.
To control your camera:
• If available, use the control software that came with your camera; or
• Send serial commands to your camera via the IP Engine. Use the Port Communication tab in
Coyote’s Configuration dialog.
To configure your IP Engine:
• Set the IP Engine to expect the images of the correct size and type for your camera. Use the
Grabber and Image tabs in the Coyote’s Configuration dialog.
To configure Coyote to receive images:
• Set Coyote to begin receiving images from your camera via the IP Engine. Use the Acquisition tab
on Coyote’s main page.

Common image capture troubles
In some cases, a working camera seems to not work due to a small issue.

Low light and bright light cameras
Some cameras are designed to work with very low light or very bright light. When exposed to the light
levels typical of an office, the image may be completely white/black, giving the impression that no
signal is being received.
When Coyote isn’t receiving any image from the camera, it displays a gray screen.
To test for low/bright light cameras:
• If the image is white, cover the camera lens. If the image is dark, shine a bright light into the lens.
• If the camera required more or less light, the image will brighten or darken.

Incorrect image size
If Coyote expects to receive a larger image than your camera sends, Coyote may discard the image as
bad.
To test for incorrect image size settings:
• Set the width and height settings to a value equal to or lower than your camera image size. In
Coyote, click Configure, then select the Image tab.
• In the Acquisition tab, enable Keep partial images.
If the expected image size was too large, partial or distorted images will appear.
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Awaiting trigger
Some cameras won’t send an image without receiving a trigger input.
To determine if your camera is awaiting a trigger signal:
• Consult your camera’s documentation. Common terms include free-running, auto retrigger,
continuous trigger, continuous acquisition, and rolling shutter.
If your camera can be set in free-running mode, images will appear. Some cameras require a
continuous enable signal to remain in free-running mode.
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Using the iPORT SDK

Now that you’ve successfully connected to your iPORT IP Engine and acquired your first images,
you’re ready to begin developing your own application.
Included in your eBUS-Vision Package are sample applications, the iPORT Concepts Guide, and the
iPORT C++ SDK Reference Guide (which contains directions for setting up your compiler and many
example programs).
We encourage you to use the samples as a framework for creating your own application. As you become
familiar with the SDK, we’re confident that you’ll find it a flexible tool for harnessing the power of
your iPORT IP Engine.
To access the samples:
From the Windows Start menu, select Start > All Programs > Pleora Technologies Inc > eBUSVision Package > Code Samples.
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Technical support

If you’re having problems, the first place to look is in the documentation accompanying documentation.
In particular, the iPORT Concepts Guide explains many topics that have been traditional trouble spots
for our customers. The following are good sources of additional information and help. For best results,
please read the entire section before deciding how to proceed.

Camera documentation
Cameras are complicated devices with many settings and features; many image-acquisition troubles are
actually a misconfiguration or a working camera awaiting a trigger signal. For additional information,
consult the documentation that accompanied your camera.

Pleora Resource Center
At the Resource Center, you can:
• download the latest software.
• view documentation for current and past releases.
• get presentations and application notes.
• get the latest news and information about our products.
• decide which of Pleora’s products work best for you.
To visit the Resource Center:
1.
2.

Log in to www.pleora.com/ and click.
If you haven’t logged in before, you’ll be prompted to sign in.
Accounts are typically validated within one business day.

Pleora Support Portal
At the Support Portal, you can:
• browse for solutions to problems other customers have encountered.
• log a support issue.
To visit the Support Portal:
1.
2.
3.

Go to www.pleora.com and click Help & Support.
If you haven’t logged in before, you’ll be prompted to sign in.
Accounts are typically validated within one business day.
If you can’t find an existing solution in the knowledge base, post a question by clicking Log a
Case. Provide as many specific details about your system and the nature of the issue as possible.

NOTE! Pleora’s support email address has been deprecated and is no longer actively monitored. To
contact support, use the support portal.
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